SpeedoMeter behaves weirdly

Hi All,
I have this problem since four days. My 96 Honda Civic Speedo Meter is behaving weirdly. When I start the car in the Morning it is not working. After couple
minutes/miles, it starts working again. I couldn't say when it is working and not working. And it turns to zero again. And after few minutes it starts working again.
I would be glad if someone can help me out with their experience.
Thanks, Ram
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Maybe a bad VSS(vehicle speed sensor)?? Or a wiring/connector problem.
Maybe a bad VSS connector problem. IIRC,the VSS is somewhere on the transmission.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I agree with the above. My parents just went through the same issue with their early 90's Acccord. Although the dealer service dept was told that it was an intermittent problem (many times a day), they some how diagnosed it as a bad odometer/instrument cluster. They claimed they never saw a bad VSS before. But since the cruise control would also cut out whenever the speedo dropped out, I assumed it was the VSS. Also, the auto tranny D4 light started to come on/blink. Apparently the transmission couldn't understand why it was in higher gears, but going 0 mph!
Sure enough, replacing the VSS a few weeks later cured all the problems. J.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Well, you all have solved my problem too -- my symptoms are identical, and I'm grateful!
If you don't mind, what did the VSS replacement set your parents back?
Thanks, Jerry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the messages. I will update with whatever my mechanic says.
- R
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ram wrote:

I told that to a traffic cop. He still booked me.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.