Speedometer problem (weird)

I have a 96 accord LX... (276 000 km..sort of)
Yesterday, the speedometer went haywire. It seems to stick on 28 km/h. When you slow down to stop, it kind of bounces, but doesn't go to 0.When you turn
off the ignition, it goes to 0?? Sometimes, it seems to work fine.. and then goes haywire again..
Does anyone here know what the cause may be????
BD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Wild guess;something in the display itself(instrument cluster) is sticking. Maybe it's gotten dirty inside,or some lubricant has finally evaporated completely.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Search a bit on line and you'll find more info, especially the VSS (Vehicle Speed Sensor) and/or speedometer. Quite expensive to replace. I ended up buying a nice gps with mounting system instead for less (previous 95 accord). Car is now sold, gps still with me:-) P.S. Gps is more accurate than speedometer..

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A GPS...
Hmmm that may be a good idea... Rats, xmas last week.
I will look around for some info.
Thanks, BD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.