Stubborn 92 Accord

I have a 92 Accord that has been acting up the past few months starting. Seems to mostly occur after it has ran for a short time, shut off for a couple of hours, start back up for a 2 minute drive and shut off, then it
will turn over but doesn't seem to want to fire at all. Most of the time, If I wait another 10 minutes or so after trying, it will start right up and run perfect. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
main fuel relay located under dash,to the left of steering wheel. Google will help you out just fine.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

main relay;see www,tegger.com
It energizes the fuel pump,and gets cracks in the relay solder joints,becomes heat sensitive;opens in hot weather,works when it cools down.You can open up the relay and resolder the PCB,or you can buy a new relay for $50 or more. Once soldered,it becomes very reliable.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Awesome, I'll break out the soldering iron!
Thanks all!!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.