suspension

hey well im having a suspension problem on my 94 integra ls. The front left tire rubs and slams everytime i make a sharp left turn. Sometimes is not even sharp turn just simple turn a bit fast and the
tire will rub, i can actually smell the tire burning. However if i made a right turn at the same speed or faster no rubbing or slaming will happen on the right side. my car has 17 wheel w/205/ 40tires. does anybody know why it does that,
thanks for the suggestions
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jack up and put your Integra's front on jackstands (like $10 at Wal-Mart or maybe Autozone). Put a piece of cardboard down on the floor. Set trusted spouse or significant other behind the wheel, with instructions to keep their hands off the ignition key. With you beneath the car, have him/her turn the steering wheel through its full range a few times. Watch for the tire hitting the frame. Inspect all components and compare to the other side.
Google for details of checking ball joints, tie rods, CV joints. If you have no idea what any of these are, do the check above and report back.
Meanwhile, I wouldn't drive this car. See for example the outcome of a failed ball joint at http://www.tegger.com/hondafaq/lowerballjoint/index.html . Or the outcome for a guy who did not use the correct bolt in his suspension at http://www.honda-tech.com/zerothread/1663809 (post by 18-year-old "Vincepru")

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks for the advice and i will try that out Elle wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hi well i also wanted to mention that about a year ago i hit an island going around 35mph on the same side that the car rubs. after that incident my wheel looked like a pie with out a slice and only after this incident did the rubbing begin. i had my axle rebuilt and i upgraded my suspension to tokiko springs and gas shocks. i have recently inspected my ball joint and it did not seem to be damaged. bui i will check the rest of the suspension components, thanks for your time.
Elle wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.