04 sonata check engine light

Hi , I have a 2004 sonata with the 2.4 dohc ,We keep getting a check eng. light comeing on with the code of P446 evap system ,we have taken it in to the dealer 4 times now and they replaced parts each time an
said its ok now Each time it lasted less than one day before it came back on up until they replaced a pressure valveon the fuel tank,Well its has been ok now for 4 months now its comeing back on with the same code(I have a scanner for the OBD11 systems) but all along they have been telling us that its because we live on a dirt road here in Az, I think this is BS, altho each time I change the oil every3000 miles (which is once a month)I use my air hose an blow gun anblow dust out from the evap canister which is mounted at the rear of the car behind the left rear tire (great place to put it) Have installed mud flaps to try to deter some of the dust but didnt help much .Now so far they havent charged me but this is a real pian in the butt. Now the road we live on is only 2miles long and we drive at25mph on it . my question is,Is this car built NOT to drive on dirt roads ? Or is it the evap is just a bad design? thanks for any advice Slim
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just as dirt roads require you to replace the air filter more frequently, you may also need to replace your canister filter more frequently. The dealer could be entirely off base, but what they've told you is plausible.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well slimone, I have to say, i drive the exact same car, 2.4 EFI, petrol, '04 Sonata, but the Aussie model, I do about the same travel as you, and 80-90% of it is on dirt, of badly surfaced roads, and I have never had any of these symptoms at all.... While Hyundai is paying for it, take it back to them and insist they find the prob, or find yourself a really good, trustworthy mechanic.... Hyundai dont always know the problems, as I found with my 1995 excell i had previous to my Sonata, as only my mechanic found the reason for my issues..... a lousy distributor caused a missfire, yet three local mechanics and Hyundai themselves could not find the prob...

http://www.autoforumz.com/Hyundai-04-sonata-check-engine-light-ftopict112535.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"slimone" wrote: > Hi , I have a 2004 sonata with the 2.4 dohc ,We keep getting a > check eng. light comeing on with the code of P446 evap system > ,we have taken it in to the dealer 4 times now and they > replaced parts each time an said its ok now Each time it > lasted less than one day before it came back on up until they > replaced a pressure valveon the fuel tank,Well its has been ok > now for 4 months now its comeing back on with the same code(I > have a scanner for the OBD11 systems) but all along they have > been telling us that its because we live on a dirt road here > in Az, I think this is BS, altho each time I change the oil > every3000 miles (which is once a month)I use my air hose an > blow gun anblow dust out from the evap canister which is > mounted at the rear of the car behind the left rear tire > (great place to put it) Have installed mud flaps to try to > deter some of the dust but didn't help much .Now so far they > haven't charged me but this is a real pian in the butt. Now > the road we live on is only 2miles long and we drive at25mph > on it . my question is,Is this car built NOT to drive on dirt > roads ? Or is it the evap is just a bad design? thanks for > any advice Slim
The code P446 evap system is the code for the vacuum system for the gas tank. There is proably a leak in the air valve for the gas tank, or when you put gas in, the cap is not on tight enough. The car is safe to drive and is not leaking any gas, only air. Eather way the only way for the light to go off you need to reset the code.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.