1998 Sonta Stalling occasionally

1998 Sonta 126k~2.0L Hello everyone. It will sputter & stall in and out when restarted from short trips (2-8+ miles) BUT, not always and will eventually stop sputtering
It FEELS as if: 1- the ignition on all 4 plugs has failed. (coil or transistor module..??) Or 2-As if I'm losing fuel pressure.
-Plugs and ignition wires were recently replaced -Last 3 years I've been averaging ~3,000 miles per year. Once or twice a month, I've been driving her 20-30 miles nonstop at highways speeds.. .(charge up the battery, remove any moisture, clean out her pipes, etc.)
I just got a fuel filter, but the darn thing is tight as heck! I spayed liquid wrench over night, I'll be getting a new flare type 14mm open end wrench this week and hopefully it will have a much better grip. Next on my to do list is the fuel tank strainer ..
Money is tight.... Any help is greatly appreciated. Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ALSO..according to my manual, the relay for the fuel pump is located bottom side panel on the passenger side.. this is a multiple relay that shuts down the whole MFI.. is there a separate relay?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Visit your local parts tore, such as Advanced Auto, and they will hook you to the computer for free. That may tell you what you need to know so you don't blindly throw money at it. Even new plugs and wires can go bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thank you Ed, I see you're still around :) Hyundai tech, mike?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 7/18/2011 2:30 PM, Ed Pawlowski wrote:

An alternative: if you have a buddy who has a code reader, you may be able to connect it and see if the computer's registered the same codes. I'm saying this because I know that one or two auto parts chains offer this service, but their local stores in my area do not.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dave;
I'm not sure if you have been following my posts and similar issues with my wife's 2003 Sonata. I have replaced the plugs, wires, lower O2 sensors and the coil pack. Still the problem persists. I'm at the point now of replacing the MAF. $49 from Ebay- OEM quality, 2 year warranty. BTW- Same MAF- 1999-2005 Sonatas, 4 or 6 cyl....
It should be here tomorrow, will keep you posted...
Steve
"Dave" wrote in message
1998 Sonta 126k~2.0L Hello everyone. It will sputter & stall in and out when restarted from short trips (2-8+ miles) BUT, not always and will eventually stop sputtering It FEELS as if: 1- the ignition on all 4 plugs has failed. (coil or transistor module..??) Or 2-As if I'm losing fuel pressure.
-Plugs and ignition wires were recently replaced -Last 3 years I've been averaging ~3,000 miles per year. Once or twice a month, I've been driving her 20-30 miles nonstop at highways speeds.. .(charge up the battery, remove any moisture, clean out her pipes, etc.)
I just got a fuel filter, but the darn thing is tight as heck! I spayed liquid wrench over night, I'll be getting a new flare type 14mm open end wrench this week and hopefully it will have a much better grip. Next on my to do list is the fuel tank strainer ..
Money is tight.... Any help is greatly appreciated. Dave
No trees were killed in the sending of this message. However a large number of electrons were terribly inconvenienced.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I realize this has been quite a while, but if you're still hunting the problem, some more information may prove helpful.
We need to determine whether the engine stops running. What do you mean by "stalls in and out?"
Sputtering often indicates a misfire or low fuel pressure. If the ignition on all four plugs fails, your engine will stop running immediately.
Does the issue occur while driving or when stopped?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.