2000 Accent Problems

Hey Guys,
For the past year or so, when I go out to start my car after it has been sitting overnight or for 8+ hours, it will start, but immediatley
after, the engine starts rumbling and misfiring ALOT (I'm talking like the whole front end is shaking), and usually the car will die after 5-6 seconds of this. The second time starting it, it is fine. It does this every morning religiously in hot or cold weather. I had it taken in to a friend of mine's shop, but he couldn't fix the problem. Any ideas? Also in the morning, when I am backing up and turning the wheel, I hear a very loud squeaking noise from a belt, and when I put it in drive to go forward, it is VERY LOUD for a few seconds until the wheel has straightened and I have driven forward for 5-6 seconds. When my car is in park and the engine is on, and I turn my wheel all the way to the right or the left, I also hear a very loud squeaking from a belt Now, sometimes sitting at a red light, I can hear a slight squeak every 4-5 seconds. Any help would be appreciated!
Noah
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Someone knowledgeable and competent will need to investigate the misfire. It could be caused by ignition, fuel delivery, or mechanical problems. Most misfire issues are caused by ignition problems, but the fact that you don't mention any misfires after the car warms a little leads me to believe that there may be some other problem here.
Your squealing is most likely due to a loose alternator/water pump belt.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.