2000 Sonata fuel control

After a LOT of different opinions and work, going on months now, after having the head pulled twice and all sorts of excitement, the car now runs (sort of). I took it back finally and decided to check into it
myself.
The injectors on cylinders 1 and 3 are wide open. 2 and 4 seem to be cycling normally. If I disconnect 1 and 3, the engine runs just as you'd expect with two dead cylinders. When they're reconnected, it runs very rough, and I suppose that's why they were convinced it was a timing problem intially. Swapping the injectors around makes no difference, it's not a mechanical problem with them, and from what I could trace by sight, it looks like there're two wire pairs, but for 1-2 and 3-4, so why one of each pair?
This thing's been through dealership mechanics and another shop, both of which pulled the head, so it's very possible that something's either not connected or not connected properly, or the entire problem was with a module. I just don't want to deal with any of these "professionals" now if I can help it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What DTC's do you have? I'm presuming you have some.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hyundaitech wrote:

No check engine light or anything, I'll check anyway though.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What symptoms do you have?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry. Definitely a brain fart here. I forgot the content of your original post and was too lazy too look at it. Did you run a test that positively confirms the injectors are open or are you basing this conclusion on how the engine is running? Do you know what a noid light is, and if so, do you have one?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hyundaitech wrote:

Just checking the voltage, it varies as expected while disconnected, but once connected to the injector it runs a steady 12v. I got an ECM from a wrecking yard, and it then had three working cylinders. I assume that it's the ECM at this point, though I returned the almost-functional one. Apparently those aren't rebuilt by anyone I could locate, over $600 shipped from Korea.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.