2002 Sonata Climate Control

My sonata has the automatic climate control without knobs and without the cabin filter. The fan will only turn on if you select the highest speed. All
the other functions seem to work like normal, meaning no matter what the fan speed is set at I can change modes for the vent positions, temp control, AC on or off, ambient outside temp. Obviously the Auto mode doesn't work to control the fan either, but it does change the vents and the L.E.D. fan speed indicator changes as I change the temperature settings. Does this mean that the climate control is bad or is there something else wrong such as sensor, wiring ect...
Thanks, Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The control commands high speed by grounding a relay. Other speeds are commanded by duty cycling a power transistor. There are several possibilities, but I'll give you ten to one odds the problem is the power transistor.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

And that looks to be located somewhere near the blower according to the schematic. Thanks for the tip!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I can't recall whether it's behind the center of the dash or in the blower box where the resistor would normally be. The schematics have links at the bottom of the page. One of these is for a component location index. Follow a couple links, and voila, you've got a nice picture of whatever dealie you're looking for.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Unfortunitly the PT isn't the issue or at least not all of it. Installing a new one didn't resolve the problem. Do you have any other ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's possible the issue is in the wiring or the climate control itself. Neither of these is a high frequency failure and the climate control head is rather expensive. I'd therefore recommend spending the time to check the wiring thoroughly.
Unplug the power transistor. Check to see if you have voltage present in the Black/Orange wire. It may be somewhat reduced from 12V (depending on your testing device) because it goes through the blower windings prior to arriving at the power transistor.
Check for ground in the black wire. You already know the connection at the ground location is good because the fan works on high speed and this uses the same ground lug. Your voltage between the black/orange wire and this wire should be very close to the same thing you got in the above test.
Check for continuity in the Green/Black wire. You'll need to remove and unplug the control head and check from one end to the other. Also check to make sure this wire isn't shorted to ground (i.e. check the resistance between the wire and a verified ground and verify it's an open circuit).
If these three wiring tests check out and the power transistor is known to be good, then you have a defective control head.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.