2004 Hyundai Elantra GT stalls continually

I have a 2004 Hyundai Elantra GT with 28,000 miles. It is a 5 speed.
About two weeks ago I filled my gas tank up, and within a day the car started to buck and shudder when I accelerated, and seemed like it
wanted to stall when I had the clutch depressed or had it in neutral.
I figured it may have been bad gas as the problems stopped when the gas tank went to about a quarter tank.
This past weekend I filled the tank again. Within one day, the car stalled on me six times within a 5 mile area. It stalled when I stopped and was in neutral, and it also stalled when I would depress the clutch to shift.
The car now stalls within three minutes at idle, in neutral.
Needless to say I can't drive the car.
The dealer now has the car and they said it stalled for them only once at a stop light.
They told me they have no idea what the problem could be, but they are researching it.
Anyone here have any ideas?
Note, that the temperature here has been in the 90's for the past few days.
Thanks
pug
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's rare, but I've heard of instances where the charcoal canister fills with fuel and then the fuel gets sucked into the intake and effectively floods the engine whenever the computer initiates vapor purge. I've seen only one car like this, but the fuel literally ran out of the canister when we removed it and turned it up.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 2002 Elantra GT just started doing this yesterday. Could be bad gas as I just filled the tank the day before. It’s also hot here.
Have you found out what the problem was with yours?
"pug" wrote: > I have a 2004 Hyundai Elantra GT with 28,000 miles. It is a 5 > speed. > > About two weeks ago I filled my gas tank up, and within a day > the car > started to buck and shudder when I accelerated, and seemed > like it > wanted to stall when I had the clutch depressed or had it in > neutral. > > I figured it may have been bad gas as the problems stopped > when the > gas tank went to about a quarter tank. > > This past weekend I filled the tank again. Within one day, the > car > stalled on me six times within a 5 mile area. It stalled when > I > stopped and was in neutral, and it also stalled when I would > depress > the clutch to shift. > > The car now stalls within three minutes at idle, in neutral. > > Needless to say I can't drive the car. > > The dealer now has the car and they said it stalled for them > only once > at a stop light. > > They told me they have no idea what the problem could be, but > they are > researching it. > > Anyone here have any ideas? > > Note, that the temperature here has been in the 90's for the > past few > days. > > Thanks > > pug
--
Posted at author's request, using fully moderated
http://www.AutoBoardz.com/Elantra-forum-93.html interface
  Click to see the full signature.
Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try removing the gas cap and see if it still stalls.

Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
pug wrote:

Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
pug wrote:

Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've had the same problem with my car, take it into a hyundai garage and get them to check for recalls, mine had a recall on the manifold, and also on some petrol pipes and other parts to do with the petrol.
pug wrote:

Add pictures here
βœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.