2012 elantra almost stalls

idling at lights, hard to start after driving parking and starting again. dealership told me to change gas to mid-grade every 3rd tank. Or maybe the throttle plate. Seeing tons of complaints and don't know what to do. It was very
intermittent now happing with more frequency. Any help with be great! Afraid to drive the car
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
While I don't have many answers, I can tell you that using 87 octane gasoline is not your problem. The vehicle is designed to run on this gasoline and using it will not cause improper vehicle operation.
In what way is the vehicle hard to start after leaving sit for short periods of time? I.e., what specific symptoms are you referring to when you say "hard to start?"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to hyundaitech , Jo Ann wrote:

gasoline and using it will not cause improper vehicle operation.

"hard to start?"
It is very hard to start after short trips or when im starting out in the morning. and I recently took a hour ride on a highway and when I came to a red light the car was shaking violently and I thought it was going to stall. The battery has been ruled out - even though its almost 4 years old. I switched to the mid-grade the car and the car violent coughs to someone trying to clear their throat. Alot smoother but I can only guess its how the engine is handling the gas? Im at a loss and dont know what to do. The dealership mentioned ther throttle plate - whatever that is. I has been doing this since i bought the car. I keep seeing the same problem of some hyundai threads with no resolution. Thank you fro trying to help me!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Find another dealer.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 12/14/2014 5:18 PM, Jo Ann wrote:

First check for any vacuum leaks. If you can't find a leak, check the idle air control valve. My guess is that's the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.