2013 Elantra Limited, odd noise

Sometimes when I start the car I hear a kind of "whirring" sound, this increases in pitch as if something is winding up, so to speak. The sound disappears after several seconds, and does not occur at every start.
Anyone have an idea what this might be? The car only has 4k miles on it. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 8/28/2014 5:54 AM, MelFranks wrote:

It's your alternator.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 8/28/2014 5:35 PM, dsi1 wrote:

No. It's my mother in law. She sits in the back seat. She loves pepperoni pizzas but they don't go down so good. You should hear when she belches.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sunday, August 31, 2014 8:29:59 AM UTC-10, Richard Steinfeld wrote:

What the heck is she doing in the OP's back seat? Come to think of it, that's not such a bad idea. I'd be even willing to pay for all shipping costs for that deal.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thursday, August 28, 2014 11:54:09 AM UTC-4, MelFranks wrote:

It's the oil flowing through the passages in the timing cover as the pressure builds up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.