99 Tiburon Trans Problem - Revisted

Allright Hyundaitech..I have a good one for you. You might remember me with all my transmission issues. I took the car to the dealer on Monday and the
service manager advised that it was the pulse generators that went bad again. He said that they need to order the parts and he will have them in on Wednesday(today). I called him today to follow up, and he said they found the underlying problem with the sensors going out so often...My "Electronic Control Module" is faulty and I need a new one. He said it is under warranty and he will have it for me tomorrow. Does this diagnosis sound right to you? Per your suggestion, I went to the Hyundai Service Technology website and looked up the tech articles on pulse generators and I dont remember reading anything about replacing the Electronic Control Module. Thanks for your input!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 05 Oct 2005 15:09:32 -0400, "andyaztec"

Don't know what Hyundaitech thinks but as an old electronics tech it's common to have a problem in a controller blows the sensors that feed it. Basically you lower the input resistance enough to draw excessive current but not low enough to blow it instantly. The result is lower service life. I would feel good that the tech was thorough enough to find the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.