Battery cable loose

I have a 2008 Sonata. I removed the cables from the battery to charge it, after the battery went dead. The battery is not the original.
When I went to re-install the positive cable, I found that cannot get the clamp
to stay on the post. There is a plastic shield that goes under the clamp, to probably protect it from corrosion.
With this shield in place, I cannot get the clamp to sit low enough on the post, to get it to stay in place. Is there a way to get a good connection while continuing to use this shield?
Thanks,
KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Monday, February 4, 2013 8:57:29 PM UTC-7, Kirk Matheson wrote:

clamp to stay on the post. There is a plastic shield that goes under the clamp, to probably protect it from corrosion.

post, to get it to stay in place. Is there a way to get a good connection while continuing to use this shield?

Turns out that there are *battery post shims* just for this purpose. I got a pair at the parts store. I will give them a try.
KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kirk Matheson wrote:

Interesting! Thanks for the update.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wednesday, February 6, 2013 5:23:46 PM UTC-7, Paul in Houston TX wrote:

They worked perfectly. The clamps are now tight, and I can't wiggle them loose.
KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.