Current drain through alternator

I'm posting this in case someone else has a similar problem. About a yr ago, my '99 Accent would crank slowly if left for more than 2 days. I had both the battery and alternator checked and they were ok. Using my
multimeter I found out I had a power off current drain of 250ma through the ECU circuit. Everything ran fine with the car except the current drain, so the short term fix was to pull the ECU fuse under the hood when not using the car. It started to bug me so I traced the circuits attached to the ECU fuse, and this includes the alternator sensing wire. I disconnected the alt. plug and the drain went to almost zero. I replaced the alternate and all is well. Even though the alternator checked out OK, it really wasn't. Maybe someone else has a similar experience.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sbiddle wrote:

I'd hack in a relay to 'click' the alternator off when you're not running. Its an ugly hack, but cheaper than a new computer...
The alternator doesn't dictate when its field is activated, its 100% controlled by the (apparently slightly disfunctional) computer. Computer is a couple hundred USD, plus I believe labor (will need to be 'keyed' for the car) is required unless you happen to have a hyundai proprietary programming tool :)
JS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I thought it was the computer at first, and I replaced it with a junkyard unit, but that didn't fix the problem. I thought of wiring the computer circuit to a relay, but I'm glad I fixed it by finding out it was the alternator. I sleep better at night now!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.