Elantra GT 2001 - Odd Halogen bulb socket behavior

I too hav noticed the shortened life of the H7 and highbeam style bulbs on my hyundai.
I recently installed a high beam bulb and I noticed that the metal spring
clip which holds the bulb in place actually glowed light red with heat as soon as I turned them on to check that they worked. First time I had seen that. It went out shortly after.
Any clues as to what's causing this and what a soultion might be?
--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail /

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Stanley P Pickens wrote:

It sounds like you've got a serious problem, such as the light grounding/shorting through the clip. Get it checked out before you damage the headlight assembly or start a fire.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually, the high beam bulb (not an H7) is designed to ground through the clip. Make sure everything is attached securely. If you've burned the plating off the clip or other contact points in the lamp, you may need to replace the headlamp assembly.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.