flashing red light on dash

A red light on the dash of my 2012 Sonata GLS has began to flash with engine off and key out and sold red when then goes out when I insert the key.
I have searched the manual and looked under theft-deterrent but have
not been able to turn it off.
It just began doing this earlier today.
Any help????
Charlie
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like what my 2007 and 2010 Sonatas have done. What are you trying to turn of?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Sine I did not see the light flashing when I first got the car I was trying to turn it back off.
For what it worth, neither my 2000 Sonata or my 2009 KIA Optima did this.
I am sure that I would have noticed it on the 2012 Sonata if it had been doing this since day one. It was only yesterday that I went on-line and did any of the registration work on the Hyundai web site. I am now wondering if that is that activated the device via its satellite connectively.
Earlier today I stopped by the dealership and asked some questions of the service rep. I now know that his only expertise is in writing up service orders. He didn't even know about the red light until I actually invited him outside and showed it to him. He was clueless. The owners manual is not a lot of help because it is not specific to any one option package but addresses all with the proviso (if equipped).
Anyhow thanks for the response and I figure now that it is doing what it is supposed to do. I tested it by leaving a window down, removing the key, getting out and locking the door with the remote. Then I reached through the open window and opened the door with the inside handle. The horn started sounding off.. Obviously a rudimentary alarm system. I looked into the Blue Link options and decided not to subscribe. My travels are almost 100% around town and back home with the car spending all the nights in my garage. Didn't figure that given my use pattern the Blue Link package is worth the cost.
Also I already have a portable Garmin GPS to direct me where I want to go if needed. And I can take that out of the car and carry it with me.
Charlie
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'd agree with you. I had two cars with ONStar and did not sign up after the trial period. Too much money for the potential benefits. I'd not sign up for the Blue Link either. I have a Garmin and just bought a new model that I'm taking to Italy with me. You can't do that with the high price nav systems built into cars. A fellow at work as an Infiniti with navigation and he says the Garmin in his wife's car is better.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
replying to Charlie, Brenda wrote: you probably are now noticing the light because its getting darker earlier. I just recently discovered mine because I didn't see it in the light of day
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 24 Nov 2015 15:18:01 +0000, Brenda

Well thank goodness you answered that 4 year old message. I certainly hope the OP stuck around for 4 years waiting for an answer.
--
To reply via e-mail, remove The Obvious and .invalid from my e-mail address.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 27 Nov 2015 07:09:16 -0800, Evan Platt

GoogleGroupers are a little slow.
--
Web based forums are like subscribing to 10 different newspapers
and having to visit 10 different news stands to pickup each one.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Worse than google groups - MotorsForum. Crappy web interface to usenet.
--
To reply via e-mail, remove The Obvious and .invalid from my e-mail address.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's an indication that the security system is active on the car. It should have been flashing from the day you bought the vehicle.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.