heating problem

hi i own a 2000 Tiburon 4cyl 16valve DOHC with 123 000 KM or 73000 mi i think.. i live in canada so its -20/-30°C outside.. my car usually takes 10-15 minutes to heat up to normal temperature (the gauge on the dash goes
to normal) but now it only takes 1-2 minutes to get to normal (but doesnt pass the normal mark) also the fans dont work.. i turn on the forced air to "4" (the highest) and nothing comes out.. (i need it to defrost the windows and prevent condensation which kinda make me drive blind lol) i already cheked the leves of antifreeze and engine oil and everything i could think of.. anyone has an idea of what could be the problem ? maybe the thermostat or something? thanks
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you mean no air comes out or only cold air comes out? If it's the former, you likely have one common problem. You'll need to perform an audit of the cooling system operation. This means you'll need to check the level of the coolant in the radiator as well as verify that the coolant flows and the fans operate when the coolant reaches the proper temperature. You shouldn't drive the vehicle until you get this sorted out. Depending on the situation, your engine could run hot without the gauge indicating such, and result in damage to the engine.
If you mean that no air blows, you'll also need to check the blower fan circuit.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.