Indicator light panel and parking lights

I just bought a 2007 hyundai tucson about a month ago. Everything was working fine until this evening. I got into my car, went to turn the lights on and the ligh panel would not illuminate, nor would the parking
lights come one. Everything else works, my regular lights work it is just the parking lights and indicator panel that won't turn on. Any suggestions?
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Given the model, it is probably still under warranty so a trip to the dealer is in order.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

But I'd check the fuses first.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

But fuses don't just blow spontaneously very often. If that is the case, he also needs to find the cause.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Absolutely. Sometimes they do blow over time, owing to marginal draw conditions, but even at that, I agree that he needs to determine the ultimate cause. Just thought I'd point out what used to be the obvious, but seems to not be so obvious to car owners anymore.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your outside lamps carefully. If it's just one side that's out, check the tail lamp fuse for that side of the vehicle. If both sides are out, check the tail lamp relay and the switch.
If the fuse is blown, finding an intermittent short may be difficult. That circuit goes numerous places (as indicated by the lamps that are out) both inside and outside the vehicle. If something was recently added on to the lamps or the dash area, it's possible there's a problem with the installation. Otherwise, it's likely that a wire was pinched at the factory during assembly. Definitely consider taking to dealer for warranty service.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.