My car has the shakes

Have a 95 Elantra 1.8 auto OD 151K The whole car shakes in neutral More so when put into drive Not a problem that has suddenly happened Been doing it for a long time. Checked balance shaft 20K
miles ago when TB& WP were changed seemed to be correctly timed I'm thinking the trans mount is bad ??? Right track or any idea's
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does the vibration get worse or better when the engine is revved (in neutral)?
The mounts that are suspect are the one on the left side of the car at the top of the engine and the one on the right on top of the trans.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mainly noticed when stopped, Does smooth out when reved in neutral
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a motor mount issue then. Balance shaft vibrations are about the same frequency at idle, but they get worse when revved.
In fact, there may be no evidence of cracking or anything visually detectable with the mounts. They may have simply sagged a little.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.