new brake sound

I just installed new rotors and pads on the front of my 2000 Sonata and everything was fine the first day. The following day I noticed a slight metallic rubbing sound, mostly from the front driver side wheel. I took
it back to my mechanic, he test drove it, and he said I should give it time and allow the pads to wear evenly and it should go away. Is this true? Do new pads and rotors need a "breaking in" time that is accompanied by some noise?
The brakes seem to work fine, no problems there. Its just this sound that has me concerned.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@cogeco.ca wrote:

Yes, although with all new parts, it shouldn't take long. If it's still making noise after a week of use, I'd bring it back and insist on having it examined.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the quick reply. Today is the first day after installation and my mechanic said after a couple of days, bring it in if it persists. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Another question, if I do have to take it back after a few days, what may be causing this noise as its definitely the new parts. My mechanic also said a possibility was a cleaning product he used to clean the grease off the new rotors. This compound may still be on the rotors a bit and causing the noise? Ever hear of this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If the noise occurs when you're not braking, the backing plate may have been bent during servicing and is now rubbing the rotor.
If it occurs when braking, it's possible your mechanic is correct. I haven't heard of any issues with chemicals causing this, but I suppose it's possible that it could be due to some interaction with the rotor. Some rotors come with a painted surface and make a similar noise until the paint wears off. It's also possible it's a noise characteristic of the brake pad material.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks for the reply hyundaitech. The noise only occurs during braking.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.