Noise on start up

Hopefully someone can help with this. I bought a used Amica (W reg) last June. Had a load of niggles, covered under warranty but one thing is still not rectified and it is really annoying. One of the
things that went wrong was an 'engine plug' of some sort, the garage had it for 3 weeks while they sorted, had trouble getting the part apparently as the car was more than 6 years old!! Since having this fixed when I start the car there is a high pitched noise which gets higher and faster until I reach revs which take me into 3rd gear approx and then it stops and is okay from then on, until the next time I start the engine. The garage thought it was to do with the Drive belts as there had a 'chirping' noise before and they thought that was the belts and they tightened them up, when I reported this latest noise I think they just presumed it was related without actually hearing the noise!! Does anyone have any idea what this could be to give me some inkling what this could be, I need to make sure that it will be under the warranty given to me with the car which was for 3 years. Lynn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What year car? What engine?
Your best bet might be to take the car to your service center (garage) the evening before they plan to work on it. Leave it with them overnight so they can hear the noise the next morning when they come in and start the car cold.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.