Replacement Aux Jack (07 Elantra)

The aux jack on my 07 Elantra SE has gone wonky, with the left speakers cutting in and out (speakers work fine with the radio). I regard my car as my mobile iPod listening system, so this is a crisis!
(Kidding just a little bit, as I couldn't endure my commute without bopping along to my iPod.) I believe that widgets like the aux jack aren't covered after the first year. Anybody have a ballpark estimate what it would run me to have the dealer replace the aux jack unit? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

This isn't necessarily in the jack. It could be in the jack, the wiring, the adapter cable, or the radio, presuming the issue isn't with your iPod.
First, make sure you're using the factory adapter cable. I've heard that there have been issues with using other cables. Perhaps even wiggle the cable around a little and see if there's any change. If so, expect the issue to be with the cable, the jack connection, or the iPod connection.
If that doesn't sort anything out, take it to the dealer to be checked. The warranty on the radio is 3/36*, and I believe the warranty on the wiring and jack is 5/60*. I'd need to run the part number through Hyundai to be certain on the latter. The warranty on the cable will depend on whether it came with the vehicle, was purchased along with the vehicle, or was purchased later. In the first two cases, it should be covered under the 5/60* new vehicle warranty, while in the latter, you'd have a 1/12* parts purchase warranty.
* warranty periods are in the format years/milesx1000
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thank you for your very detailed response! I have checked the iPod and it works fine with headphones. I tried another cable, although I don't use the "factory" cable (Hyundai sent a cable to me several months after I bought the car -- is that what you're referring to?), but one I bought for myself. I've used the cables I bought for close to 3 years without any problems. The left speakers work fine when I have the radio on, no static, no cutting in and out. The cables I bought have right angle connectors, which are supposed to be much easier on jacks than straight connectors.
When I wiggle the cable in the jack, that causes the left speaker to cut in and out, which made me think that the problem was the jack itself. I'll make an appointment with the dealer. Thanks again for responding so quickly and with such thoroughness!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fantine wrote: <snip>

I had the same problem with the headphone jack on my cordless phone. I was prepared to buy a new phone, but I tried some contact cleaner, and the problem went away. I was surprised, because I really thought the jack was totally shot.
--
PB
"I suspect you're an arrogant little pissant who grew up in the
Red Bull generation." - CJW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If Hyundai sent you a cable, then that would be the one I'd recommend trying. You are probably correct that the issue is in the jack, but it's possible there's some issue with the way these cables fit into the jack which has only become a problem over a period of time.

Take the cables you have and be sure to tell the dealer that wiggling the cable in the jack causes the speaker to cut in and out. This will make the diagnosis (and your visit) much shorter.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If there are any miniature phone plugs in your cabling, these can make poor contact. Finger oils and other films can interfere with contact. There are a few different failure points with this type of connector; can't say that I like them.
Get a can of aerosol contact cleaner/lube from an electronics parts store. There aren't too many of these places any more.
Give each jack a squirt, quickly put the plug back in; rotate the plug and push it in and out a few times. This should wipe any crud off the connecions. Then give the jack/plug another little squirt for good luck. The residue (you won't see it) will actually improve contact into the future.
The other thing to check is whether the problem is in the plug/jack contact or due to intermittent contact failure between the wires and the plug itself. Incredibly common failure due to the stupid design of the plugs and inadequate wires. In this case, just replace the cable; never yank on it.
See if any of this works before doing anything more costly.
Richard
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Oct 30, 5:03am, Richard Steinfeld

Thanks for all the replies. I dug out the cable that Hyundai sent me and try that tomorrow. I'll update with the results.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

OK, I removed the old cable and used the cable that Hyundai sent me. And guess what? No problems! I had thought that since I had reversed the old cable, that it wasn't the problem, but I guess I was wrong. I'll keep on using that cable this week, and see what happens. Thanks again for all the help, folks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fantine wrote:

Well, just keep my advice for the future (and for all electronics that use mini phone plugs). Broken leads are the most common failures in these products due to junk quality. The "strain relief" on the plugs is just for show: it doesn't work. There isn't any. Therefore, never yank on the wires. In fact, don't even pull on them.
Richard
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.