Sonata headlamps won't come on

The headlamps on my 2008 Sonata will not turn on.
The parking lights, turn signals, and tail lights are fine.
I do know that the headlights will only turn on if the ignition switch is in the "on" position.
Could this be something simple, such as a fuse, or is it most likely a relay?
Thanks,
KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Believe it or not, the number one cause of this is two burned out bulbs.
Do the high beams work? If so, it could be a fuse or relay. As far as possibilities go, it could also be the switch or a faulty ground.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Friday, September 26, 2014 3:15:05 PM UTC-6, hyundaitech wrote:

You are correct. Both bulbs were burned out. I have never had this happen before. Usually they fail one at a time.
I took it to a shop, because I was sure that it was going to be more than just the bulbs.
They only charged me for the bulbs, so it didn't cost much. Thanks for the repy.
-KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
They do fail one at a time, but most people don't notice until the second one goes out. Some people drive around for months with one light out.
"Kirk Matheson" wrote in message
On Friday, September 26, 2014 3:15:05 PM UTC-6, hyundaitech wrote:

You are correct. Both bulbs were burned out. I have never had this happen before. Usually they fail one at a time.
I took it to a shop, because I was sure that it was going to be more than just the bulbs.
They only charged me for the bulbs, so it didn't cost much. Thanks for the repy.
-KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

True, but I can't imagine how numb those people are though. You'd think at some point they would look at the reflection pulling into the parking spot at the 7-11 or notice tail lights uneven backing into a parking spot, etc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Monday, September 29, 2014 8:18:23 PM UTC-6, Partner wrote:

That may be what happened. I noticed several other cars with only one headlamp working while mine were out.
KM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.