Strange problem with EXCEL 1.3 (year: 1995)

Hello,
My Dutch Hyundai EXCEL 1,3L has a very strange electronical problem, which occurs regularly, but more often since a week :cry: .
During the ride the engine starts to vibrate more than normally (maybe
due to inefficient combustion????), whereafter the CHECK ENGINE light is displayed. The problem recently occured sometimes without the CHECK ENGINE light going on as well.
Then suddenly all power flows away, till the speed is near zero, and after that the engine suddenly starts to run at maximum revs. During this whole process the engine doesnt at all react on the accelerator.
The Hyundai dealer tried to remedy the problem by replacing the crankshaft position sensor, because that had happened to be a weak part of the EXCEL-series. The repair didnt help.
Do you know a solution :idea: ?
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like your transmission is slipping. Did the dealer check for trouble codes? I would think that there would be something stored since the check engine lamp came on. If so, what codes did they find?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote: > Sounds like your transmission is slipping. Did the dealer > check for > trouble codes? I would think that there would be something > stored since > the check engine lamp came on. If so, what codes did they > find?
Thanx for your reaction.
After several checks a mechanic discovered that the coolant temperature sensor disturbed.
A normal coolant temperature is 85 deg Celsius (355 Kelvin), but the disturbing sensor measured data fluctuating from 85 deg to minus 15 deg Celsius.
The specific sensor has been replaced and now the EXCEL works properly.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.