Sudden Loss of Power on Elantra

I have a 2005 Elantra 5-speed manual with 52K miles.
For the most part it runs fine but all of a sudden I have a loss of power.
If I depress the clutch and pump the gas, it picks up again. It also
periodically stalls.
The other night it was stalling out while I was coasting with the clutch depressed and the trans. in neutral so I don't think it's a clutch problem.
It tends to happen more when it's cold but the problem is intermittent.
Any suggestions would be appreciated.
Thanks.
- PAUL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

A clogged fuel filter?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the check engine lamp on?
There are many possibilities. Without more information, I might suggest checking for a vacuum leak or, depending on exactly what happens and at what temperatures, perhaps reprogram the ECM.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It turns out it is a computer part, and fortunately it's under warrantee. I don't have the part name but I will know tomorrow after they replace it in case anyone wants to know.
Thanks for the suggestions.
--
PAUL

"paul" < snipped-for-privacy@yahoo.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.