Tuson

I have a 2005 (6 cycl) Tuson. I found it this morning wounded. It hesitates off the line. It stalled for my wife today. When it gets going I don't feel
or hear any missing. Only from a standing start does she hesitate. We just filled up at the same station we always do. By the way, it was very cold last night.
Let me know what ya think
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the air intake hose to see if it's come loose from the air flow sensor.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check the MAP sensor. It probibly had some condinsation in it that froze and stopped the diaphram from moving with pressure changes. Good luck Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Err...ummm not here in Australia....my 2007 Tucson shows "Tuscan" on the rego papers and label.
Neville Cootamundra Australia
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.