1999 Rodeo irratic idle and jerky transmission

I recently started having this problem with my 99 rodeo. it's a v6 2wd. probably within the past 6 months, the idle has gotten more and more irratic. it will idle from 300 to
2000 back to 300 up to 2000, and so on. this sounds as if someone is in the car just mashing and releasing the gas pedal. it does all of this on its own tho. sometimes it even drops so low it dies. i believe i have narrowed this down to the upper intake manifold gasket (air plenum). a new problem has arisen within the past week and it may or may not be related to this. every time i mash the gas when i am already at a complete stop, the car acts like it doesn't want to go. it'll shoot the rpms way up like it's in neutral and then it'll jerk back down into gear. sometimes it will even do this twice before it goes forward 15 feet. if anyone else has had these problems, please respond. i'm hoping the problems are related and that it's just a simple fix. thanks for any help, steve.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@somedomain.com.invalid wrote:

The idle problem could be a vacuum leak.
For the other problem, I would start by checking the fluid in the transmission, assuming you have an automatic. When was the last time you had the transmission fluid and filter changed?
Edd
-=-=- ... Beware of those who suffer from delusions of adequacy!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If there is an idle control solenoid on the air plenum it could be the problem. It's held on with two small torx screws. If it is it's a GM part readily available. Ron
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Change 2 gasket intak, 4hour!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote: > I recently started having this problem with my 99 rodeo. it's > a v6 2wd. probably within the past > 6 months, the idle has gotten more and more irratic. it will > idle from 300 to 2000 back to 300 up > to 2000, and so on. this sounds as if someone is in the car > just mashing and releasing the gas > pedal. it does all of this on its own tho. sometimes it even > drops so low it dies. i believe i have > narrowed this down to the upper intake manifold gasket (air > plenum). a new problem has arisen > within the past week and it may or may not be related to this. > every time i mash the gas when i > am already at a complete stop, the car acts like it doesn't > want to go. it'll shoot the rpms way up > like it's in neutral and then it'll jerk back down into gear. > sometimes it will even do this twice before > it goes forward 15 feet. if anyone else has had these > problems, please respond. i'm hoping the > problems are related and that it's just a simple fix. > thanks for any help, > steve.
Hi I have read your post, Im having exacly the same proplems with the transmission. I have change the "mode switch $175", and still doing the same. Have you fix yours? If you did fix it. can you please help me telling me how?
Thank you.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.