95 Rodeo Speedometer / Idle Problems

I have a 1995 Isuzu Rodeo. Recently, the speedometer has stopped working. So the speed is always shown at 0 mph. Also, recently after driving for a while and slowing down to make a turn,
the engine will die...I can then just put it in neutral and restart and go. Doesn't happen alot. But at least once a week. Any ideas as to what could cause this? And if anyone else had the same issue, the estimated costs to repair? Thanks!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like you have a broken speedometer driven gear, about $30 from a dealer. It is a simple part to replace, with the only needed tool being a 10mm socket to remove the outer part of the sending unit, located on the passenger side of the trans. It is an electric sending unit, so just look for the wire harness connection just ahead of the forward U-joint. When you remove the 10mm bolt the inner part is a nylon gear on a post which you will probably notice has several teeth missing. Just replace that part and not the entire sending unit, which costs considerably more. When my speedometer went out, I kept having stalling problems because the computer was not receiving the correct speed signal from the sending unit. Don't know if replacing the gear will fix your stalling problem, but it did mine. Good luck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you very, very much. I will try that this weekend and let you know how it went.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you thank you very much. That appears to have taken care of both problems. The speedometer works and the engine has not died. I would have never found that 10mm bolt without your assistance and I'm extremely grateful.
Thank you again!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hey, i am having the same problem with my 95 rodeo too the speedometer just stopped working while i was driving it and the check engine light came on. it hasn't stalled yet on me but i haven't driven it since then. my husband is going to do everything that you did and hopefully it will work for us too. i just wanted to let you know that it isn't an isolated incident. anyways. you havning your problem was helpful to us figureing out what to try before we pay an arm and a leg for a 30 dollar part we can fix ourselves. so thank you and i will let you know if it works for us too. Brittany
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.