96 rodeo running hot

My rodeo keeps losing water and running hot, can't find a leak, tried stop leak, still losing water. Also the check engine light has been on forever. Any help will be appreciated.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you checked your oil level, or your reservoir? If either one is high, you probably have a head problem.
David

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BTW, if your oil level is high, don't start the engine. Have it towed to your garage.
David

stop
forever.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Probably a bad water pump.
I had to replace My pump last weekend. You will see fluid leaking on the front cross suspension bars.
Gary

stop
forever.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
noname wrote:

If you see no leak then you may have a cracked head or a blown head gasket. If it has overheated severely thats an easy way to blow a head gasket or warp the head. Check your oil. Does it appear greyish? That would indicate water.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your coolant reservior and see if you see oil, and check the oil dip stick. If there is a leak through the head, then you could see the foam like stuff at the oil dip stick
Did you check the thermostat? It can cause overheat as well. Sometime it get stuck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.