'99 Trooper Drive-line noise

'99 Trooper 3.5 gas, (U.S.) with TOD. 31.5K miles, bought new 8/'99
As this is principally a street driven vehicle I seldom engage the awd feature, typically on rainy days. Recently I have noticed a very
light whirring clatter sound emanating from the front of the vehicle. This ONLY occurs while in awd high. Most noticeable under light to moderate acceleration 30 to 50 mph. I have heard it at hwy speeds, but at that point wind noise mostly drowns it out. The sound is never heard in 2wd.
I did a search in the Isuzu section on www.4x4wire.com but came up with nothing.
I took it to the local Isuzu dealer and they were unable to determine a source of the noise. I was then given a lecture that the vehicle should not be driven on dry pavement in awd. The ignorant service salesman wasn't even aware of the TOD functions!
Any suggestions or clues as to cause?
TIA
Max, in Houston, TX
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the tip, Bret. I'll check it, but I would hope it is properly filled as the vehicle just had its 30K service at the dealer about 6 weeks ago.
Max
On Wed, 2 Jul 2003 19:00:27 -0400, "Bret Chase"

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.