99 Trooper Stall and CEL

I have a 99 Trooper and began from least April, the CEL keeps coming on when the engine speed reach 3500+ rpm, and engine stalls in front of traffic lights or when I shift from P to R. I went to AutoZone a few
times and got code 137 157 171 1171. Most of them are about low voltage in oxygen sensor, lean in fuel mix. I also went to dealer for 5 times. The first time they changed the intake gasket (the second change, the first time was in 2001), later they asked me to use better gas, in the most recent trip, they asked me to change fuel filter and fuel pump. I changed fuel filter and the problem was still there.
I am wondering what cause this problem (CEL and stalls). The followings are the possible reason my friends and dealers gave me:
1. Intake Gasket.
2. Oxygen sensor.
3. Fuel pump.
4. ERG valve.
5. Something else?
My fellow Trooper fan, can you guys use your expertise and give me some suggestions? Thanks! Peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

time to SELL!
ray
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's the intake gaskets. Their famous for leaking.
Nate

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check your gas filler cap gasket
Peterisme wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.