Check Engine Light ON

Hi,
I have a Honda Passport (97) (Rodeo), and I had a Check Engine Light on three days, and after this, it is off. I noticed that this happens after a car wash, but I am not sure if this is related.
Should I bring the car to a Honda or isuzu dealer? Is this issue important?
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
cUcU wrote:

Did you by chance just get gas while at the car wash? If so, your gas cap could be leaking or not on tight. Before going to a dealer, take it to the nearest AutoZone and ask them to read the computer codes. They will do so free of charge. That will give you and idea of what the problem might be. Hopefully it will be something simple.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thnaks. I will check the codes in AutoZone, but so far, the check engine light is off. So maybe the problem is gone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
cUcU wrote:

The code should be stored and will still come up. Might let ya know of a pending problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 91 Rodeo did that about every other time I took it through a car wash. It was water getting into one of the under hood electrical circuits causing a false reading. I found that if I washed it myself in the drive & let it sit for 15 minutes it never happened.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.