Help!! My Rodeo Stalls Out!!!

I have a 2001 Isuzu Rodeo with 125,000 miles on it, if the car has been sitting for more than 4 or hours, I go to start it and it runs rough and stalls out. It will do this 3 or 4 times until it runs okay.
If I rev on the gas, it will back fire but help speed up the process. I have replaced the mass air flow sensor, all new spark plugs, cleaned the ERG line, replaced the air filter and the fuel filter. I also put High octane gas in it! Please help I want my car fixed.
Ashleigh
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you regularly "top off" when filling the gas tank? If so it's likely your evaporative loss canister (aka charcoal canister) has been contaminated with liquid gasoline, not just the vapors for which is designed to collect and release back into the fuel supply. As a test, you can remove and plug the hose going to the canister and see if that solves your problem. If so you need a new canister. Note that the check engine light will likely come on while the canister is disconnected and the canister is a vital part of the emmissions system and it is illegal to operate the vehicle without one. However, I'm sure you can get away with it for a few days for testing purposes.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.