P0401 code on 1997 Isuzu rodeo

I am getting a P0401 code on a 1997 Isuzu Rodeo V6 engine with approximately 140,000 miles. EGR valve has been replace a few years ago. The check engine light comes on and sets the P0401 code when the
fuel tank is 1/4 tank full or less. When you fill the tank with gas the check engine light goes out after you drive the vehicle for a while and cycle the engine on and off. The check engine light will come on when the tank again drops below 1/4 full. Any ideas as to the problem.
John Holley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a similar problem on my '98 Amigo 2.2L 4 cyl. I just bought an ODB-II reader and I haven't run it low enough to get a code and I had disconnect the battery for another repair. Do you have any other codes present?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Forgot to mention, that when the tank gets to about 1/8 the gas guage goes nuts. It will jump to 1/2 indicated, then slowly drop to near empty.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ed wrote:

No, that is the only code that is set and the gas gauge does not jump but is steady. I have seen some online diagnostic services state the 401 code is based on the interaction between the MAP sensor and the EGR valve. Since the EGR has been changed once already and I am on the original MAP sensor maybe I need a new MAP sensor. I can pick one up for about $50 online so maybe that is the way to go. The EGR is anywhere from $90 to $150 online. I don't like the idea of just swapping parts hence the posting to see if anyone can help troubleshoot or advise of similar condition and their solution.
John Holley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try cleaning your EGR pipe. I am about to do the same to attempt to kill my codes.
http://www.automotiveforums.com/vbulletin/showthread.php?p 77258#post1777258
snipped-for-privacy@gmail.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kaz wrote:

Guys make sure your gas caps o ring is in good shape that bring up the same code for some stupid reason
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.