P0463 Fuel Level Sensor Circuit High Input

I was reading the posts you guys put and it was as if someone else was describing my vehicle. I started with a check engine ligth when the gauge approached empty. Then came the blinking fuel light with the
check engine, and now I fill up and get about 200miles before my gauge shows empty. Has anyone pinpointed down the part and repair since these posts? I want to do the work myself to save the labor costs and I have access to a lift, but was wondering if anyone had actually bought the parts, attempted the repairs, and the results. any help would be greatly appreciated.
jh
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, that's apparently a known issue, and of course, not under warranty unless the whole fuel pump goes bad.
What you need to get done is change out the "Fuel Sending Unit". Its in the gas tank near the float. I got it done at the dealer for $260. Not cheap, but I had not other option. It seems like you do, so let me help you out even further:
http://www.planetisuzoo.com/articles.htm?id 6&Replacing_the_Fuel_Sending_Unit_on_a_2nd_Gen_Isuzu_Rodeo
I hop this helps!
Carlos

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.