torque on demand "TOD"

My 2001 trooper with 75,000 miles has the 4wheel drive/TOD indicator lights on the left dash. When in 2 wheel drive mode only the rear wheel lights are
lit up. When in TOD or 4WD mode the rear and front (or part of front for TOD) are lit up. For the last 2 weeks the rear wheel indicator lights have been blinking, this is only in 2WD, any other mode all lights are constant. Front and rear differentials are full, no loose wires, vehicle runs and drives just fine. Can anyone tell me what is wrong with the indicator lights,why they are blinking. When this first started i could shift to 4WD and back to 2WD and it would stop., now it is constant unless i am in 4WD or TOD.
What should be the max speed in TOD mode?
NEEDING HELP, thanx
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I just had the wheel speed sensors replaced on my 2002 w/TOD. There is a red "check" light at the bottom of the TOD wheel lights that was on. Sounds like you need a trip to a dealers shop too.
AG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I believe there was a posting about that or something like it here a while back - apparently a common problem is a solenoid in the front end that engages/disengages the system that stops functioning properly...? Maybe someone else remembers the details better...
Wesley

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.