trouble starting and knocking noise in idle after it warms up (30 miles or so)

Help! We purchase a 2000 Trooper noticed a slight ping/knocking noise in the first month. Several months later noise is more often and now we are having trouble starting. You start it, it dies, about 2 to 3 times. I read
the article on the pinging noise took off and cleaned the EGR but not sure I torn it down far enough. We have changed inline gas filter, air filter, and cleaned EGR any other ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
tjcoutryheart wrote:

Just a suggestion: My Isuzu is earlier so this wouldn't apply and I'm not familiar with the later models but with my 97 T-Bird the exact same problem was caused by a dirty MAF (mass air flow) sensor. In the case of my Bird the sensor looks like the filament in a light bulb and as air passes over it, it tells the computer how much fuel the engine needs. Over time it collects fine particles of dust. Need a residue free cleaner with a brush (radio shack) to clean. Depending on accessibility its an easy project (but delicate). Made a huge difference in my case. Ended ping, added much HP.
Did a google search on Isuze+MAF and got some feedback so apparently you would have some sort of MAF.
Good luck.
Frank
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.