(VERY HIGH IDLE) 4,500 rpm as soon as engine starts

I went out this morning to start my 1996 2.2L 4cyl. isuzu hombre, when it turned over and started, it immediatly went to 4500 rpmís and didnít go down. I did push the accelator once this happened to see if
this was stuck..but this did not help. I then opened the hood to check to see if the throttle body cables were messed up, they looked and felt ok!! ---What "sensors" (and/or) "valves" could be messed up??? and what would you check after you do the ACCELORATOR TEST????
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"optagon" wrote: > I went out this morning to start my 1996 2.2L 4cyl. isuzu > hombre, when it turned over and started, it immediatly went to > 4500 rpm's and didn't go down. I did push the accelator once > this happened to see if this was stuck..but this did not help. > I then opened the hood to check to see if the throttle body > cables were messed up, they looked and felt ok!! > ---What "sensors" (and/or) "valves" could be messed up??? and > what would you check after you do the ACCELORATOR TEST????
Well...i gave up on this and took it into the isuzu dealer, come to find out it was the "upper plemium gasket" that was leaking---they replaced it in a few hours and now it runs PERFECT---Of all things- it was a gasket!!! L.O.L ---amount to fix 1) Labor#9.95 2) Parts).43 3) Misc shop supplies$.00 4) TAX=4.41
TOTAL COST)7.79--i considered this was pretty good!
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.