190E odd front vibration

All,
My wifes 1984 190E has developed an odd vibration. At 25 MPH it vibrates from the front suspension. I have narrowed it down to something on the right side. I have replaced the Drag-link, cause it
wasn't in good shape, struts are sound, verified the bearing s have no excessive play, and cannot detect any movement in the ball joints.
I am leaning towards the tie rods (I would replace both sides, they are only 30 bucks, and can be replaced in about 15 minutes), but still cant be sure. Could it still be a bearing? The vibration goes away if I turn left, it is onlt present when going straight, and is very pronounced when turning right.
Thanks
Thom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mount the spare tire on the right front and try it, if no change try it on the left to ensure its tire isn't the cause. This no cost exercise will find or exclude a bad tire.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Possibly a separating tire. I would do this test too... It could be bearing or lower control arm.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
T.G. Lambach wrote:

Thanks, I'll try the tire. I can detect no movement at all in the lower control arm, ball joint or bearing no matter how hard I tug, so maybe the tire is causing it, I sure hope so.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Swap the wheels left to right and see if that changes the problem any.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tire swap (left to right) didn't work. While swaping fron to back, tire would not roll nice. I found a 2/3" rise on the insire tread. VIOLA!! problem solved. Thanks. I always over look the simple things.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.