190e various questions.

Hello again Mercediacs!
I am still here in Seattle and I am still driving my 1986 190e. It's got about 132K miles on the odometer now, and has been performing
flawlessly for me since I got it when my wife was pregnant (our daughter is 3 now!). I did do a bunch of work on it when I first got it including the serpentine belt tensioner, and other front of engine accessories.
I recently did experience a failure of the central locking system, which fixed itself when I took the vacuum pump apart (under the rear seat passenger side). Don't really know if this was just a loose connector?
1) So, is there a general issue with the vacuum pump that cause is to fail? Are there several common scenarios?
2) Where is the illumination for the gear selector read out? This has never worked.
3) The reserve fuel lamp has never lit for me? Is this usually a bulb? If so, how to get it?
I am sure I had other questions, but for now... This would help.
Thanks and I hope you are all doing well? are you all still here? Did Mcbrue get a Lexus?
Add pictures here
āœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

With the age of the car, it is most likely the pump just worn out. Buy another used one from ebay and you should be fine.

There is a bulb on that gear selector... you have to take out the wood trim... then on the top left hand side, you will see a bulb socket... it is those tiny bulb.

It is most likely the fuel sender is clogged with debris that prevent the reserve light from coming on... I suggest you buy a new unit instead.

Yes, McBrue bought a Lexus... he got alot smarter now... he spoke normal english now.

Add pictures here
āœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What do you get for mileage in your 190E?

Add pictures here
āœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I use it almost exclusively for city driving and get in the low 20's (21-24MPG).
Quite an upgrade from my previous car a 1968 buick gs 350!
Marty
Add pictures here
āœ–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.