1972 280SE 4.5L timing/vacuum

Can anyone tell/reference info on the vacuum advance/retard aspects of the Starting Valve, Thermal Time Line Switch, Supplemental Air Valve, Cooling Temp Sensor, &
Switch-Over Valve/relay, for the above mentioned car? It goes from purr to cough & back & I suspect the ingition timing-vacuum continuum.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would suspect the points in the distributor... much more common problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sorry, failed to mention Petronix electronic ignition.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Before you mess with that have you verified the injection rack moves freely?
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Injection rack on a 72 280SEL 4.5?!?
That engine has EFI......
I would suspect the cold start valve first. When it idles rough, clamp off the hose at the cold start valve. If it smoothens out, replace the cold start valve.
If it does not help, I would remove the distributor and take a look at the trigger points. They may have oil on them......
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.