1984 300D Turbo Combination Switch...

Greetings all,
I cannot get the windshield washer switch on the end of the combination switch to work. Tested this down to a bad switch or wires. I took the switch
on the end off and checked for continuity and found NONE on the #10 wire. The #11 wire is good because I can get the wiper motor to work in both speeds. The pump motor is good because I tested it with 12 volts and it ran. I am suspecting an open/broken wire due to 21 years of flexing.
------ Does anyone who might be parting out a 1984 300D Turbo have one they might be interested in sending my way?-----
AND while I had the car torn apart, I checked to see what was the matter with the door locking system. Seems that the yellow with red tracer plastic tubing that runs from the passenger (Right) front floor to the switch in the door assembly had a crack where the tubing leaves the car and enters the door. Looks like about 2 meters of this tubing and I will be back in full service for the 1st time in the 6 years that I have owned the car. The testing was way too easy. Started at the passengers side and split the system. Found the problem in the door, but then had to isolate it to a bad diaphragm or bad tubing. My mighty Mite Vacuum tester was the best investment I've made in a long time...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.