1990 300CE instrument cluster removal

I've seen posts here about removing the instrument cluster from various models, but they don't seem to quite apply to my 90 CE. The puling of the panel is not the problem, but how to get slack in the speedpo cable.
I removed the lower carpet, but it doesn't seem to be clipped or retained in any way. Is loosening from under the car the only way?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I believe one needs to reach the speedometer cable's connection to the speedometer from underneath the dash board. I was able to unscrew the connection by reaching along side the cluster but later had to reconnect it by reaching up from below - 300SD experience. Expect some scrapes to your arm.
--
2007 T.G.Lambach. Publication in any form requires prior written
permission.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"-->> T.G. Lambach <<--" <"T.G. Lambach at NoHamorSpamcomcast.net"> wrote:

Thanks for the replies!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If it is like some the 190 2.6 you may have to loosen the cable at the transmission just to get enough slack to pull the cluster out enough to unfasten the speedo cable. Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.