1990 mercedes 190E petrol 2.0

when hot, over-flowing from expansion tank.Problem started when,cooling system drained & changed anti-freeze,till then running o.k. Since 1st problem, have changed cyl head(vacuum & pressure tested & skimmed)Used
merc gasket & new bolts & still the same problem,New thermostat no difference.Radiator checked o.k.dont know if fan is cutting in.Can you help.Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
shortyone wrote:

Silly question, did you replace the radiator cap?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could it be air bound?
The problem arose only after the coolant was drained and replaced.
Some cars get an air bubble trapped in the cooling system that needs to be bled out. This car may be one of those.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Water pump gummed up from flush?
Collin KC8TKA E320/97
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had a similar problem, but mine was due to the head gasket blown, this then blew hot gases in the water coolant system, which inturn blew the coolant out of the expansion tank.
Might help
Regards
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.