1992 190E 2.3 Cold Start

Car has 92,000 miles on it. Every morning when I start the car, the car will turn over then die. This happens about 4 times then it will stay on. Whenever
the car sits for about an hour, it does the same as above. Not the fuel pump, it was replaced. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

will turn over then die. This happens about 4 times then it will stay on. Whenever the car sits for about an hour, it does the same as above. Not the fuel pump, it was replaced. Any ideas?

Fuel Pump Relay.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cossie, So what does that mean? The Fuel Pump was replaced a year ago? Do I need to buy another one or do you make some sort of adjustment on it? Thanks for the help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I need to buy another one or do you make some sort of adjustment on it? Thanks for the help.

The fuel pump and the fuel pump relay are two different things. The relay is known to go bad on these cars (it did on mine), and that failure can manifest itself in various ways, one of which you described as your problem. When mine went out, it started by stalling right after start up, then after the second start it would run fine. Then after a while it started to get worse, until the car quit while cruising down the road at 50 mph - just like I had turned off the key. I put in a new fuel pump relay (this was about 3 years ago) and haven't had a problem since.
The relay is a cigarette sized black box that plugs into a socket under the hood (not sure of the exact position in your car - either by the fuse box or behind the battery.
Bill Balmer 1986 190E 2.3-16 first 16V in the US featured in Car & Driver - March, 1986
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bill, Just want to thank you! Bought the Fuel Pump Relay off the internet ($117 vs $175 @Mercedes), put it in myself and the car has been fine since. Thanks again, Jon
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
put it in myself and the car has been fine since. Thanks again, Jon

If anyone here is a former teacher, professor, mentor, or general acquaintance of mine:
HA! I'M GOOD FOR SOMETHING AFTER ALL!!!!! ;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.