1993 300e 2.8 slipping transmission

My trnasmission is slipping when shifting into 3 and 4th, it wasn't untill mechanic pulled out old modulator and replace a broken gasket. A like "black" capped modulator was put back in, apparently used and
car still slips when under acceleration now, old modulator was put back in with new gasket and still slips, any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
As usual, your mechanic did not adjust the accumulator after he installed it. You can do it yourself... Take the black cap out if you have one... then pull out the T handle slightly so you can turn it... and then turn it in clockwise 1 turn 180 degree... put cap back on... and test drive. Repeat until you feel the shift is firm but not rough.
Counter clockwise to soften the shift.
If you don't have the black cap, and instead got a white dial... same story... turn it clockwise until the shift is firm.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

THANK YOU WILL FORARD THIS WITH THE CAR ON THE WRECKER TOMMOROW, HE WANTS THE CAR WHILE COLD.........THANK YOU SO MUCH REGARDS STEPHEN
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

MAYBE THIS MIGHT BE OTHER INFO, HE WENT TO A GREEN CAP, SAME PROBLEM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You are referring to the color of the modulator... yes, there are a couple of colors... red, green and black.
You are supposed to install the same color as the one you removed... they are not the same.
Adjustment is all the same regardless of the color.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.