1999 CLK 320 - ASR/BAS Lights

99 CLK 320. Switch on and ASR/BAS light is lit and car won't start. If you cycle the ignition and try to start it quickly it will start and then die straight away, if you wait until the dash lights are
illuminted then it won't fire at all.
This has happened on two previous occasions and both times switching off then on resolved the issue but this time it's not budging!
Can anyone suggest any possible causes and solutions?
Thanks
Darren
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Change the battery. It resolved my folks 01 E320.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Over voltage protection relay itself or the fuse on top of the relay?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Could I ask where that would be located?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check around the right side shock tower in the engine bay. It used to be behind the battery in the W201/W124 era. Since the battery goes to the trunk in W202, I guess yours will be similar. The OVP has one or two fuses (usually blade type, red, 10amps) on its top. No other relay is like that.
Darren Griffin - PocketGPSWorld.Com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 2007-03-27 15:59:33 +0100, Darren Griffin - PocketGPSWorld.Com

Gave up on it for the day, re-tried the next morning and it started first time. Now two weeks later it's done it again. Bl**dy annoying!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.