2001 CLK auto wiper speed issue

Reading about other people's winscreen wiper issues reminds me that I (may) have one on my 2001 CLK (Cab). The service adviser at the dealership could
not comment but offered to have it examined at next service (which is still a long way off).
At some stage I noticed that the wiper never reaches maximum speed when set to auto. Even in heavy rain it goes to the second-to-max speed. If I want faster I have to switch it manually.
Any ideas if this is this normal?
Thanks for any comments.
DAS
--
For direct contact replace nospam with schmetterling
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks StefanHeringer.
Yes, I have the rain sensor. I should have made that clear. I had forgotten it was/is an optional extra.
My issue is not coverage (which seems ok) but speed.
DAS
....................................... You have the rain-sensor, I presume. Its the same with my 2000 Clk 55.
--
Does it wipe clean forth and back ? If not, let check the wiperarms vertical
position to the windscreen ;-\
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sometime you have to remove the cover of the wiper and relube the linkage... they do get dirty and dry out...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.