2001 ML320 - Central Locking Failure - Need help

As soon as I got home this morning, I turned the ignition off and removed the remote. I opened the driver's door and the chime went off and would not time out. I closed the door again and the chime went off.
I got out of the car and tried to lock the doors with the remote. The doors and tailgate did not lock. Now I can only lock the doors using the key. Tried my wife's remote and the malfunction persisted. At least the symptom is repeatable, not intermittent.
Note: The tumbler in the ignition switch was replaced by the dealer in May of this year due to problems with the locking/alarm system. It took ONLY seven trips to the dealership to have the problem fixed!
Please help me before I go nuts.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
So far nobody has replied to my cry for help. Any ideas regarding my locking system problem are very much needed and appreciated. The factory warranty expired this past May 26th.
Hernando Correa wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do they use vacumm or are they the electric type these days?If electric,maybe fuse is blown or a ground failed!I could write on the head of a match what I know about door locks but trying to help nonetheless,best of luck!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, Captain, for your comments. I thought I was crying in the wilderness...
The locking system is all electric these days. That's why is so tough to diagnose and fix the malfunctions without the computerized tools that are available to the dealerships. RATS!
CaptainW116 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In Hernando Correa typed:

If the key has been removed from the ignition (lights off, etc), there should be no chime; sounz like a faulty computer module. I've had a few of those modules go bad on me in my 2000 ml320.

As I recall, I had a problem with the keyless entry remote not locking, I replaced the remote battery and that did not fix it, then the dealer reminded me that there is a procedure in the manual for resetting the remote where you must re-sync it by positioning the ignition switch while depressing the remote (I forget), check the manual.

I also had a problem where the alarm went off intermittently and only could be shutoff with the remote. Turned out the computer found it was a bad glass breakage sensor in the passenger door.
Best to also see what readings the Dealer can turn up when they attach their diagnostic computer.
DanlK, FYI Services Collectibles www.FYIS.org
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for your comments. I'll print them and let the service advisor read them on Monday when I take the ML for service. This would be the 8th time for the same reason! The most recent "fix" of the locking system lasted for a month and a half.
FYIS.org/ wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.